Everything that worked with Bundler 1.0 still works with Bundler 1.11, all new features from 1.0 to 1.11 have been incremental additions, without removals or deprecations. Some feature ideas that break backwards compatibility are planned for Bundler 2.0 release.

I plan to implement two features related to the first and only bundler security vulnerability, that allowed gems to be installed from a different source than expected. This includes some changes to part of the codebase that is fragile, complex and prone to bugs, to make it a drastically simplified version which would be more stable and easier to maintain.

Organization

Student

Chalkos

Mentors

  • indirect
  • segiddins
close

2016